<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie10 lt-ie9 lt-ie8 lt-ie7" ng-app="myApp" lang="en" itemscope itemtype="http://schema.org/Article" xmlns:og="http://ogp.me/ns#" xmlns:fb="https://www.facebook.com/2008/fbml"  > <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie10 lt-ie9 lt-ie8" ng-app="myApp" lang="en" itemscope itemtype="http://schema.org/Article" xmlns:og="http://ogp.me/ns#" xmlns:fb="https://www.facebook.com/2008/fbml"  > <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie10 lt-ie9" ng-app="myApp" lang="en" itemscope itemtype="http://schema.org/Article" xmlns:og="http://ogp.me/ns#" xmlns:fb="https://www.facebook.com/2008/fbml"  > <![endif]-->
<!--[if IE 9]>         <html class="no-js lt-ie10" ng-app="myApp"  lang="en" itemscope itemtype="http://schema.org/Article" xmlns:og="http://ogp.me/ns#" xmlns:fb="https://www.facebook.com/2008/fbml"  > <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" ng-app="myApp" lang="en" itemscope itemtype="http://schema.org/Article" xmlns:og="http://ogp.me/ns#" xmlns:fb="https://www.facebook.com/2008/fbml"  > <!--<![endif]-->
<head>
<meta http-equiv="X-UA-Compatible" content="text/html, charset=UTF-8, IE=edge, chrome=1">

			<link rel="canonical" href="https://election.ctvnews.ca/ndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602" />
							<link rel="alternate" media="only screen and (max-width: 640px)" href="https://election.ctvnews.ca/mobile/ndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602"/>
			<script type="text/javascript">
var videoPageUrl = "https://www.ctvnews.ca/video";
</script>
<meta name="viewport" content="initial-scale=1.0, maximum-scale=1.0, width=device-width, user-scalable = no">
    <style>
      @font-face {font-family: 'Flama-Medium';src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.eot?s=2_6780');src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.eot?#iefix&s=2_6780') format('embedded-opentype'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.woff?s=2_6780') format('woff'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/Flama-Medium.svg#font&s=2_6780') format('svg');font-weight: normal;font-style:normal;}
      @font-face {font-family: 'CTVSans-Black';src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTVSans-Black.otf?s=2_6780') format('opentype');src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTV_Sans-Black.woff?s=2_6780') format('woff'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTV_Sans-Black.ttf?s=2_6780') format('truetype');font-weight: normal;font-style:normal;}
      @font-face {font-family: 'CTVSans-Bold';src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTVSans-Bold.otf?s=2_6780') format('opentype');src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTV_Sans-Bold.woff?s=2_6780') format('woff'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTV_Sans-Bold.ttf?s=2_6780') format('truetype');font-weight: normal;font-style:normal;}
      @font-face {font-family: 'CTVSans-Regular';src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTVSans-Regular.otf?s=2_6780') format('opentype');src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTV_Sans-Regular.woff?s=2_6780') format('woff'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/CTV_Sans-Regular.ttf?s=2_6780') format('truetype');font-weight: normal;font-style:normal;}
      @font-face {font-family: 'webIconFont';src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/webiconfont-v6.eot?s=2_6780');src: url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/webiconfont-v6.woff?s=2_6780') format('woff'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/webiconfont-v6.ttf?s=2_6780') format('truetype'),url('https://static.ctvnews.ca/bellmedia/ctvnews/css/webfonts/webiconfont-v6.svg#webiconfont?s=2_6780') format('svg');font-weight: normal;font-style:normal;}
    </style> 
<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery-1.7.js"></script>
<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery.cookie.js"></script>
<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/requireDependency.js"></script>
<link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/responsive.css"/>
<script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/jquery.polopoly.js"></script>
  <script type="text/javascript" src="https://cdns.gigya.com/js/gigya.js?apiKey=3_-FVQzpdFRai9eK0LUE2bQibsUcv-mtWRgrAUaCyDvREHAAVSgJS25CWP-fZq-7hZ"></script>
  <script type="text/javascript">
    var loginWeb = "CTVnews-login-web";
    var loginMobile = "CTVnews-login-mobile";
    var profWeb = "CTVnews-profile-web";
    var profMobile = "CTVnews-profile-mobile";
		var shareProviders = "facebook,twitter,google,linkedin";
  </script>
  <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/gigya.js"></script>

<script type="text/javascript">
  var kruxID = "ImoeZsch";
</script>
<!-- END Krux Controltag -->

    <script type="text/javascript">
    requiresDependency('//auth.9c9media.ca/auth/main.js', function() {
        $(function(){
            initAuth();
        });
        function initAuth(){
            var brand = 'ctvnews';
            var platform = 'web';
            var environment = 'prod';
            
            BmAuth.init(brand, platform, environment)
            .then(function(){})
            .catch(function(errorPackage){console.log('[BmAuth] init failed', errorPackage);});
            };
            });
    </script>

                      <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/election/election-2019-grid.css" media="screen" />
                      <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/plugins/slick.css" media="screen" />
                      <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/tooltipster.css" media="screen" />
                    <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/slick/slick.min.js" ></script>
                    <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/lightbox/jquery.lightbox-0.4.min.js" ></script>
                      <link rel="stylesheet" type="text/css" href="https://static.ctvnews.ca/bellmedia/common/css/jquery.lightbox-0.4.css" media="screen" />
                    <script type="text/javascript" src="https://www.ctvnews.ca/cmlink/7.733123" ></script>
                    <script type="text/javascript" src="https://www.ctvnews.ca/cmlink/7.733165" ></script>
                    <script type="text/javascript" src="https://www.ctvnews.ca/cmlink/7.733220" ></script>
                <link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon.png">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-57x57.png" sizes="57x57">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-60x60.png" sizes="60x60">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-72x72.png" sizes="72x72">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-76x76.png" sizes="76x76">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-114x114.png" sizes="114x114">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-120x120.png" sizes="120x120">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-144x144.png" sizes="144x144">
<link rel="apple-touch-icon" href="//static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-152x152.png" sizes="152x152">

                <link rel="apple-touch-icon" type="image/png" href="https://static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon.png" /> 
                <link rel="apple-touch-icon" type="image/png" href="https://static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-72x72.png" sizes="72x72"/> 
                <link rel="apple-touch-icon" type="image/png" href="https://static.ctvnews.ca/bellmedia/ctvnews/img/apple-touch-icon-114x114.png " sizes="114x114"/> 
                <link rel="icon" type="image/ico" href="https://static.ctvnews.ca/bellmedia/common/img/favicon.ico" sizes="16x16"/> 
              
    <script type="text/javascript">
        (function() {
            /** CHARTBEAT HEADER CONFIGURATION START **/
            var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
            _sf_async_config.uid = 65778; //65778
            _sf_async_config.domain = 'ctvnews.ca'; //'ctvnews.ca';
            _sf_async_config.flickerControl = false;
            _sf_async_config.useCanonical = true;
            _sf_async_config.useCanonicalDomain = true;
            /** CHARTBEAT HEADER CONFIGURATION END **/
        })();
    </script>
    <script async="true" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>

  <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/mdetect.js"></script>
            <link rel="stylesheet" type="text/css" href="/cmlink/ctv-styles-7.132" />
          <link rel="stylesheet" type="text/css" href="/cmlink/weather-link-7.729539" />
          <link rel="stylesheet" type="text/css" href="/cmlink/responsive-override-7.726278" />
          <link rel="stylesheet" type="text/css" href="/cmlink/hide-g-7.725977" />
          <link rel="stylesheet" type="text/css" href="/cmlink/ontario2014-7.523345" />
          <link rel="stylesheet" type="text/css" href="/cmlink/video-bin-column-css-7.489853" />
          <link rel="stylesheet" type="text/css" href="/cmlink/banner-temp-7.298239" />
          <link rel="stylesheet" type="text/css" href="/cmlink/player-style-7.363763" />
          <link rel="stylesheet" type="text/css" href="/cmlink/background-override-7.682833" />
          <link rel="stylesheet" type="text/css" href="/cmlink/sponsored-articles-7.688114" />
          <link rel="stylesheet" type="text/css" href="/cmlink/jamie-hacks-7.695789" />
          <link rel="stylesheet" type="text/css" href="/cmlink/newmynews-7.701063" />
          <link rel="stylesheet" type="text/css" href="/cmlink/tsn-widget-7.701032" />
          <link rel="stylesheet" type="text/css" href="/cmlink/logo-7.726372" />
          <link rel="stylesheet" type="text/css" href="/cmlink/us-election-7.686940" />
          <link rel="stylesheet" type="text/css" href="/cmlink/budget-css-7.379739" />
          <link rel="stylesheet" type="text/css" href="/cmlink/the-pope-mini-player-7.377289" />
          <link rel="stylesheet" type="text/css" href="/cmlink/news-7.291979" />
          <link rel="stylesheet" type="text/css" href="/cmlink/line-divider-and-spacing-issues-7.583409" />
          <link rel="stylesheet" type="text/css" href="/cmlink/brightcove-responsive-7.666233" />
          <link rel="stylesheet" type="text/css" href="/cmlink/970-ad-7.682214" />
          <link rel="stylesheet" type="text/css" href="/cmlink/last-hour-countbox-7.690285" />
          <link rel="stylesheet" type="text/css" href="/cmlink/scribble-mynews-7.700231" />
          <link rel="stylesheet" type="text/css" href="/cmlink/stylesheet-7.335238" />
          <link rel="stylesheet" type="text/css" href="/cmlink/nc-trending-7.653655" />
          <link rel="stylesheet" type="text/css" href="/cmlink/blog-style-7.664074" />
          <link rel="stylesheet" type="text/css" href="/cmlink/poli-header-7.665012" />
          <link rel="stylesheet" type="text/css" href="/cmlink/election-teasers-stylesheet-7.733147" />
          <link rel="stylesheet" type="text/css" href="/cmlink/body-override-7.730841" />
    

<!--[if IE]>
  <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
<!--[if lt IE 9]>
        <script>
        document.createElement('header');
        document.createElement('nav');
        document.createElement('section');
        document.createElement('article');
        document.createElement('aside');
        document.createElement('footer');
        document.createElement('hgroup');
        </script>
        <![endif]-->
<script type="text/javascript">
if(!(window.console && console.log)) {
  console = {
    log: function(){},
    debug: function(){},
    info: function(){},
    warn: function(){},
    error: function(){}
  };
}
</script>
	    


	<!-- set index exchange script-->
				<script async src=//js-sec.indexww.com/ht/p/183816-263227036570116.js ></script>
<script>
window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
(function(){
	function retrieve(n){
		var m, k='kx'+n;
		if (window.localStorage) {
			return window.localStorage[k] || "";
		} else if (navigator.cookieEnabled) {
			m = document.cookie.match(k+'=([^;]*)');
			return (m && unescape(m[1])) || "";
		} else {
			return '';
		}
	} 
	Krux.user = retrieve('user'); 
	Krux.segments = retrieve('segs') && retrieve('segs').split(',') || [];
})();
</script>


<script type='text/javascript'>
  
  (function() {
    var useSSL = 'https:' == document.location.protocol;
    
    //creates a script tag for gpt.js
    var gads = document.createElement('script');
        gads.id = "gads";
    	gads.async = true; 
    	gads.type = 'text/javascript'; 
    	gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
   
    
    var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node); 
    
  })();
  
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
      
  googletag.cmd.push(function() {
  
                                                                                                                                            googletag.defineSlot('/5479/ctv.ctvnews/election2019/stories', [[300,100]], 'div-gpt-ad-300_100-1')
      .addService(googletag.pubads()).addService(googletag.companionAds());
    
  ;
  true;
 
                                                                                                                                                                          googletag.defineSlot('/5479/ctv.ctvnews/election2019/stories', [[30,1]], 'div-gpt-ad-30_1-2')
      .addService(googletag.pubads()).addService(googletag.companionAds());
    
  ;
  true;
 
                                                                                                                                                                          googletag.defineSlot('/5479/ctv.ctvnews/election2019/stories', [[728,90],[970,250],[970,90]], 'div-gpt-ad-728_90-3')
      .addService(googletag.pubads()).addService(googletag.companionAds());
    
  ;
  true;
 
                                                                                                                                                                          googletag.defineSlot('/5479/ctv.ctvnews/election2019/stories', [[300,250],[300,600],[300,1050]], 'div-gpt-ad-300_250-4')
            .addService(googletag.pubads()).addService(googletag.companionAds());
        
  ;
  true;
 
                                                                    
          googletag.defineOutOfPageSlot('/5479/ctv.ctvnews/election2019/stories','div-gpt-ad-outofpage-1-oop').addService(googletag.pubads()).addService(googletag.companionAds());
        
    
                                                                                    
                                                                                      
                    	
    googletag.pubads().enableVideoAds();
    googletag.pubads().collapseEmptyDivs(true);
    //NEWS-1509 - Amazon wrapper 
    googletag.pubads().disableInitialLoad();
        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
        googletag.pubads().setTargeting("ksgmnt", Krux.segments);
	googletag.pubads().setTargeting("u", Krux.user);
	  });
  
   
   
   
	//NEWS-1509 - Amazon wrapper Call
	!function(a9, a, p, s, t, A, g) {
            if (a[a9])
                return;
            function q(c, r) {
                a[a9]._Q.push([c, r])
            }
            a[a9] = {
                init: function() {
                    q("i", arguments)
                },
                fetchBids: function() {
                    q("f", arguments)
                },
                setDisplayBids: function() {},
                targetingKeys: function() {
                    return []
                },
                _Q: []
            };
            A = p.createElement(s);
            A.async = !0;
            A.src = t;
            g = p.getElementsByTagName(s)[0];
            g.parentNode.insertBefore(A, g)
        }("apstag", window, document, "script", "//c.amazon-adsystem.com/aax2/apstag.js");
         
	apstag.init({
        pubID: "3733",
        adServer: "googletag"
    });
	  
	apstag.fetchBids({
	  	slots: [{
	  		"slotID" : "div-gpt-ad-300_100-1",
	  		"slotName" : "/5479/ctv.ctvnews/election2019/stories/div-gpt-ad-300_100-1",
	  		"sizes" : [[300,100]]
	  	},{
	  		"slotID" : "div-gpt-ad-30_1-2",
	  		"slotName" : "/5479/ctv.ctvnews/election2019/stories/div-gpt-ad-30_1-2",
	  		"sizes" : [[30,1]]
	  	},{
	  		"slotID" : "div-gpt-ad-728_90-3",
	  		"slotName" : "/5479/ctv.ctvnews/election2019/stories/div-gpt-ad-728_90-3",
	  		"sizes" : [[728,90],[970,250],[970,90]]
	  	},{
	  		"slotID" : "div-gpt-ad-300_250-4",
	  		"slotName" : "/5479/ctv.ctvnews/election2019/stories/div-gpt-ad-300_250-4",
	  		"sizes" : [[300,250],[300,600],[300,1050]]
	  	}],
	  	timeout: 2e3
	  	}, function(bids){
	  		googletag.cmd.push(function(){
                apstag.setDisplayBids();
                googletag.pubads().refresh()
	  			
	  		})
	});
</script>


<script type="text/javascript">
   googletag.cmd.push(function() {
      if (typeof window.headertag === 'undefined' || window.headertag.apiReady !== true) { 
         window.headertag = googletag;
      } 
   });
</script>
<script>
    var cbAuthor;
</script>  <title>NDP Leader Jagmeet Singh campaigns in Toronto | CTV News </title>
      <meta name="description" content="Sights and sounds from the election campaign trail." />
        <meta name="keywords" content="Federal election 2019, 2019 Canadian federal election, 2019 general election, CTV Politics, Nik Nanos, " />
        <meta name="news_keywords" content="Jagmeet Singh, federal election, Justin Trudeau, Andrew Scheer, politics, #elxn43" />
  <link rel="amphtml" href="https://beta.ctvnews.ca/national/2019/9/13/1_4591602.html">
<meta name="robots" content="noarchive,noodp" />
<meta name="robots" content="noodp,noindex,nofollow" />
<meta name="robots" content="ACAP disallow-index" />
    	      		<meta property="fb:pages" content="58148619578" />
      	      		<meta property="fb:pages" content="194553860586548" />
      	      		<meta property="fb:pages" content="231176056943733" />
      	      		<meta property="fb:pages" content="174761742563060" />
      	      		<meta property="fb:pages" content="157659357620093" />
      	      		<meta property="fb:pages" content="189363054419794" />
      	<meta name="dc.date.modified" content="2019-09-13">              
                      <meta itemprop="description" content="Sights and sounds from the election campaign trail." />
                        <meta itemprop="name" content="NDP Leader Jagmeet Singh campaigns in Toronto" />
                                  <meta itemprop="url" content="https://election.ctvnews.ca/ndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602" />
                    <meta itemprop="image" content="https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_300/image.jpg" />
                    <meta property="og:type" content="article" />
          <meta property="og:title" content="NDP Leader Jagmeet Singh campaigns in Toronto" />
          <meta property="og:description" content="Sights and sounds from the election campaign trail." />
          <meta property="og:url" content="https://election.ctvnews.ca/ndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602" />
    
          <meta property="og:image" content="https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg" />
	  <meta itemprop="thumbnailUrl" content="https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_1020/image.jpg" /> <!-- schema.org -->
        <meta property="og:site_name" content="Federal Election 2019" />
                    <meta name="twitter:title" content="NDP Leader Jagmeet Singh campaigns in Toronto" />
          <meta name="twitter:url" content="https://election.ctvnews.ca/ndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602" />
          <meta name="twitter:card" content="summary_large_image" />
          <meta name="twitter:description" content="Sights and sounds from the election campaign trail." />
              <meta name="twitter:site" content="@CTVNews" />
      <meta name="twitter:creator" content="@CTVNews" />
              <meta name="twitter:image:src" content="https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg" />
              <meta itemprop="headline" content="NDP Leader Jagmeet Singh campaigns in Toronto"/>
  <meta property="og:locale" content="en_CA" />
      <meta property="article:published_time" content="2019-09-13T08:55:00-04:00"> 
  <meta itemprop="datePublished" content="2019-09-13T08:55:00-04:00">
        <meta property="article:modified_time" content="2019-09-13T11:52:00-04:00">
  <meta itemprop="dateModified" content="2019-09-13T11:52:00-04:00">
          
            <script>
        var gigTitle = "NDP Leader Jagmeet Singh campaigns in Toronto";
        var gigDesc = "Sights and sounds from the election campaign trail.";
        var gigURL = "https://election.ctvnews.ca/ndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602"
        var gigImg = "https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg";
      </script>
       
    <script type="application/ld+json">
    {
      "@context": "http://schema.org",
      "@type": "NewsArticle",
      "headline": "NDP Leader Jagmeet Singh campaigns in Toronto",
      "description" : "Sights and sounds from the election campaign trail.",
      "author" : {
            	      		"name": "",      		
      	              "type" : "Person"
      },
      "publisher":{
        "@type": "Organization",
               "name": "CTV News",
                "logo": {
            "@type": "ImageObject",
            "url": "https://www.ctvnews.ca/polopoly_fs/7.724917!/httpImage/image.png",            
            "width": 124,
            "height": 60
        }
      },
      "image": {
        "@type": "ImageObject",
        "url": "https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_1020/image.jpg",
        "height": 1020,
        "width": 574
      },
      "mainEntityOfPage":"https://election.ctvnews.ca/ndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602",
        		  		"dateModified": "2019-09-13T11:52:00-04:00",
  		  	  	  		  			"datePublished": "2019-09-13T08:55:00-04:00"
  		  	    }
</script>
    
  
<script type="text/javascript">
  jQuery.ajaxSetup({
    cache: 'true'
  });
</script> 
  <link rel="alternate" type="application/rss+xml" title="CTV News Weather " href="https://www.ctvnews.ca/rss/ctv-news-weather-1.4134741" />  <link rel="alternate" type="application/rss+xml" title="Most watched" href="https://www.ctvnews.ca/rss/most-watched-1.4108797" />  <link rel="alternate" type="application/rss+xml" title="Breaking news banners for external (radio)" href="https://www.ctvnews.ca/rss/breaking-news-banners-for-external-radio-1.4027508" />  <link rel="alternate" type="application/rss+xml" title="CTVNews.ca - Top Stories - Public RSS" href="https://www.ctvnews.ca/rss/ctvnews-ca-top-stories-public-rss-1.822009" />  <link rel="alternate" type="application/rss+xml" title="CTVNews.ca - Politics - Public RSS" href="https://www.ctvnews.ca/rss/politics/ctvnews-ca-politics-public-rss-1.822302" />


<script type="text/javascript" src="//assets.adobedtm.com/launch-EN8508e1965b004de29de2dbd977d7156a.min.js"></script> 
</head>

<body id="top">
<script type="text/javascript"><!--jQuery(document).ready(function() {window.pageLoaded=true});//--></script>

<!-- BEGIN BANNERS -->
<header class="banner clearfix">

  
        <div class="content-wrapper">
        



  
  
    <div class="election-leaderboard">
    <div class="ad-element">
	    	        

                                    <div class="boxAd secondClass ">
							                            <div class="advert">
        
                        
                                                                                              
                	<div id="div-gpt-ad-728_90-3" class="advert-placeholder"></div>
        
<script type="text/javascript">
	if ($(window).width() <= 768 && ("dart" == "boxAd" || "boxAd" == "boxAd") || "dart" == "dart" && $(window).width() <= 768 ) {
	  $( ".articleBody p:eq(1)" ).after($("#div-gpt-ad-728_90-3").closest(".boxAd"));
	}
</script>

  		<script type="text/javascript">
	    if (document.querySelector('.advert') !== null) {
	        googletag.cmd.push(function () {
	            headertag.display("div-gpt-ad-728_90-3");
	        });
	    }
	</script>
          
                    								<p class="ad-below">Advertisement</p>
							            </div>
                
                    </div>
        
    
  	        </div>
</div>
<section>
    <div class="election-returnhome-cta">
                        	            
        <a  href="https://www.ctvnews.ca/"   >CTV News</a>

                </div>
    <div class="election-brandlogo-cta">
                    <a href="https://election.ctvnews.ca/">
                                        <div class="image">
  <img src="https://www.ctvnews.ca/polopoly_fs/1.4483246!/httpImage/image.png_gen/derivatives/default/image.png" alt="" />
</div>
                                </a>
            </div>
    	    <div class="election-follow-cta">
	        
                              <div class="connect element none">
    <p class="title">FOLLOW ON</p>
			                            <a class="connect-facebook-icon social-icon" style="text-decoration: none !important;" href="http://facebook.com/CTVNews"></a>
                              		                            <a class="connect-twitter-icon social-icon" style="text-decoration: none !important;" href="https://twitter.com/ctvnews"></a>
            		                              <a class="connect-insta-icon social-icon" style="text-decoration: none !important;" href="https://instagram.com/ctvnews"></a>
                                        <a class="connect-youtube-icon social-icon" style="text-decoration: none !important;" href="https://youtube.com/ctvnews"></a>
                                          <a class="connect-linkedin-icon social-icon" style="text-decoration: none !important;" href="https://linkedin.com/company/ctv-news"></a>
              			</div>
		<script type="text/javascript">
    jQuery(document).ready(
      function(){
        requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/jquery.tooltipster.min.js', function() {
        $('.tooltip').tooltipster({
            arrowColor:'#F4F4F4',
            interactive: true
            });
        });
      });
    </script>	    </div>
    
    <script>
        jQuery(document).ready(function() {
            $(".banner .election-follow-cta").clone().appendTo('.content');
            if ( $('.electionArticlePrimary').length > 0 ) {
                $(".content .election-follow-cta").addClass('border-top');
            }
        });
    </script>
</section>

  
  
  
      
  <style>
					.banner .breakingNews div.BNID_74891901568392395 {background-color: #A80A01;  height:41px;}
				
     .banner .breakingNews div.content-wrapper h2.BNID_74891901568392395, .banner .breakingNews div.content-wrapper h2.BNID_74891901568392395 a {color: white;}
    .breakingnewsTag h2.BNID_74891901568392395 {color: white;}
</style>
  <article class="breakingNews">
    <div class="content-wrapper BNID_74891901568392395">
      <div class="breakingnewsTag"><h2 class="TagText BNID_74891901568392395"> BREAKING</h2><span class="tagArrow">&nbsp;</span>
      <h2 class="BNID_74891901568392395 mobi">
                                                    	              
        <a  href="https://www.ctvnews.ca/canada/rcmp-employee-charged-under-national-secrets-act-1.4591995"  title="RCMP employee charged under national secrets act" >RCMP employee charged under national secrets act</a>

                            </h2>
			      <span class="clearfix"></span>
			</div>
    </div><!-- END .content-wrapper -->
    <style>
      .banner .content-wrapper { border-bottom: none!important; }
    </style>
  </article>


  
  
  
      

  
  </div>
  </header><!-- END .banner -->
<!-- END BANNERS -->

<div class="content">
  <div class="content-wrapper">
                <div class="article-label"></div>
          
                	    	<h1  class="articleHeadline">NDP Leader Jagmeet Singh campaigns in Toronto</h1>
    			<div class="s-data">
																								<span class="date">
					Published Friday, September 13, 2019 8:55AM EDT
				</span>
				              		<span class="date">
                		Last Updated Friday, September 13, 2019 11:52AM EDT
              		</span>
            	            		</div>
            	    		<div class="playa">
  






<script>
	var vidiPlayerPath = "//webapps.9c9media.com/vidi-player/1.7.x/js/player.js";
</script>


<script type="text/javascript">

     
    // Get auth flags
    jQuery(document).unbind('isDone.renderClips').bind('isDone.renderClips', function(event) {
    
      requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/videoNavigation.js', function() {
        getAuthStates("104070,1778839,1778792,1778785,1778730", "ctvnews_web");
      });  
        
      jQuery(document).unbind('isDone.getAuthStates').bind('isDone.getAuthStates', function(event, authMap) {
                                                      for ( var contentId in authMap ) {
                                                        var lockIconClass = "noKey";
                                                        if ( authMap[contentId] == true ) {
                                                          lockIconClass = "vidKey";
                                                        } else {
                                                          lockIconClass = "noKey";
                                                          jQuery('#'+contentId+'playIcon').show();
                                                        }
                                                        
                                                        jQuery('#'+contentId+"lock").addClass(lockIconClass);
                                                      }
                                                    });
    });
  </script>

                    

<script type="text/javascript">
function isVideoPlayerSupported(){
	var videoPlayerSupported = !MobileEsp.DetectBlackBerry();
	return videoPlayerSupported;
}
</script>

    
    
  



<script>
var sampleAdZone="election2019/home";
var samplePlayerAdRule="election2019/home";
var samplePlayerAdSite="ctv.ctvnews";
</script>


  
  
        <script type="text/javascript">
      var playlist = new Array(); // Playlist used by the player
      var playlistNav = new Array(); // Playlist used by the nav
      var clipIdList = new Array(); // array of clipIds. Used to check for duplicate clips in playlist.

      var nowPlayingClipId = "";

      // navigation variables
      var maxClipsPerPage = 3;
      var currClip = 0;  // index of the current clip on this page of player nav (first clip's index is 1).

            /* new vars */
var currClipPage = 1; // page the clip is currently playing on.
var currUserPage = 1; // page the user is currently browsing.
var currHighlightedPage = 1; // page number currently highlighted in pagination.

function addClipToPlaylist(clipId, clipName, clipDesc, thumbnailUrl, thumbnailUrlNav) {
	// create clip object
	var clip = new Object();
	clip.id = clipId;
	if(typeof resourceName != 'undefined')
		clip.resourceId = resourceName;
	clip.title = clipName;
	clip.image = thumbnailUrl;
	clip.description = clipDesc;
    clip.shareableUrl = generateSharePath(clipId, videoPageUrl);
	
  // create clip object used by the nav
	var clipNav = new Object();
	clipNav.id = clipId;
	clipNav.title = clipName;
	clipNav.image = thumbnailUrlNav;
	clipNav.description = clipDesc;

	// check if we already have this clipId
	if (jQuery.inArray(clip.id, clipIdList) == -1) {
		clipIdList.push(clip.id);

		// Add clip to playlist used by the player
		playlist.push(clip);

		// Add clip to playlist used by the nav
		playlistNav.push(clipNav);
	}
}
function generateSharePath(clipId, baseSharePath) {

    if ( baseSharePath == "" ) {
    //link to video page 
    //this does not work for preview and local host
        baseSharePath = 'http://' + window.location.host +'/video';
    }

    var pathShare = baseSharePath + '?clipId=' + clipId;   

    return pathShare;
   
} 

      /* clipIndex is the index of this clip in the current page of the player nav. */
      function addClipToPlayerNav(clipId, clipName, clipDesc, clipImageUrl, clipIndex, currPage) {
        var htmlCode =  '<div class="playa-items" id="' + clipId + '" vClipTitle="' + clipName +'">';
            htmlCode += '  <div class="clip-stuff">';
            htmlCode += '     <div class="vid-title"><a href="javascript:setCurrClipPage('+ currPage +');genericPlayer_aritcleVideoContainer.playItemByContentId(' + clipId + ');setCurrClipIndex(' + clipIndex + ');highlightMobileClip('+ clipId +');">' + clipName + '</a></div>';
            htmlCode += '     <div class="vid-img">';
            htmlCode += '       <a href="javascript:setCurrClipPage('+ currPage +');genericPlayer_aritcleVideoContainer.playItemByContentId(' + clipId + ');setCurrClipIndex(' + clipIndex + ');highlightMobileClip('+ clipId +');">';
            //htmlCode += '        <div class="noKey">false</div><div class="vid">&nbsp;</div>';
            htmlCode += '          <div id="' + clipId + 'lock"></div><div id="' + clipId + 'playIcon" class="vid" style="display:none">&nbsp;</div>';
            htmlCode += '        <img src="' + clipImageUrl +'" width="95px" height="54px" />';
            htmlCode += '		<div class="now-playing"><span style="vertical-align: sub;padding:5px;">NOW PLAYING</span></div>';
            htmlCode += '       </a>';
            htmlCode += '     </div>';
            htmlCode += '     <div class="vid-desc">' + clipDesc + '</div>';
            htmlCode += '  </div>';
            //htmlCode += '  <div style="clear: both"></div>';
            htmlCode += '</div>';

        jQuery("#storyPlayerNav").append(htmlCode);
      }
    </script>
                      <div class="playa-playa election-col-8 election-col-xl-7 election-col-l-12 election-col-m-12 election-col-s-12 right-padding">
            <div id="mediaplayerdiv" class="aritcleVideoContainer"></div>
        </div>
            
                      <div id="storyPlayerNav" class="election-col-4 election-col-xl-5 election-col-l-12 election-col-m-12 election-col-s-12 left-padding electionViewForSlick">
                    </div>
        
	  	  <script>
	  	var clipArray = [];
	  </script> 	 
                      
                                  <script type="text/javascript">
        var thumbnailUrlPlayer = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
    var thumbnailUrl = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
                            thumbnailUrlPlayer = "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg";
        thumbnailUrl = "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_150/image.jpg";
        if(isVideoPlayerSupported()){
      addClipToPlaylist(104070, "LIVE: Singh speaks in Toronto", "NDP leader Jagmeet Singh speaks at the Canadian Club in Toronto on day three of the campaign trail.", thumbnailUrlPlayer, thumbnailUrl);
    }
  </script>
                        
        		<script>
			var adZone = "election2019/home";
			var adSwitch = false;

			if(adSwitch == true){
				var newClip = {
					contentId: 104070, 
					ad: { adsite: 'ctv.ctvnews', adzone: adZone },
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			} else {
				var newClip = {
					contentId: 104070, 
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			}
			clipArray.push(newClip);
		</script>
        
        
              
                                  <script type="text/javascript">
        var thumbnailUrlPlayer = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
    var thumbnailUrl = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
                    thumbnailUrlPlayer = "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg";
        thumbnailUrl = "https://www.ctvnews.ca/polopoly_fs/1.4591997.1568391274!/httpImage/image.jpg_gen/derivatives/landscape_150/image.jpg";
        if(isVideoPlayerSupported()){
      addClipToPlaylist(1778839, "Scheer\'s debate comments dominate day 3 discussion", "From CTV News Channel: Michel Boyer has the latest on the backlash to Andrew Scheers\' comment on Indigenous groups during the first debate.", thumbnailUrlPlayer, thumbnailUrl);
    }
  </script>
                        
        		<script>
			var adZone = "election2019/home";
			var adSwitch = false;

			if(adSwitch == true){
				var newClip = {
					contentId: 1778839, 
					ad: { adsite: 'ctv.ctvnews', adzone: adZone },
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			} else {
				var newClip = {
					contentId: 1778839, 
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			}
			clipArray.push(newClip);
		</script>
        
        
              
                                  <script type="text/javascript">
        var thumbnailUrlPlayer = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
    var thumbnailUrl = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
                    thumbnailUrlPlayer = "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg";
        thumbnailUrl = "https://www.ctvnews.ca/polopoly_fs/1.4591946.1568389862!/httpImage/image.jpg_gen/derivatives/landscape_150/image.jpg";
        if(isVideoPlayerSupported()){
      addClipToPlaylist(1778792, "Scheer takes questions on the campaign trail", "From CTV News Channel: Conservative Leader Andrew Scheer takes questions from the media after making an announcement in Toronto. ", thumbnailUrlPlayer, thumbnailUrl);
    }
  </script>
                        
        		<script>
			var adZone = "election2019/home";
			var adSwitch = false;

			if(adSwitch == true){
				var newClip = {
					contentId: 1778792, 
					ad: { adsite: 'ctv.ctvnews', adzone: adZone },
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			} else {
				var newClip = {
					contentId: 1778792, 
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			}
			clipArray.push(newClip);
		</script>
        
        
              
                                  <script type="text/javascript">
        var thumbnailUrlPlayer = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
    var thumbnailUrl = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
                    thumbnailUrlPlayer = "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg";
        thumbnailUrl = "https://www.ctvnews.ca/polopoly_fs/1.4591936.1568389528!/httpImage/image.jpg_gen/derivatives/landscape_150/image.jpg";
        if(isVideoPlayerSupported()){
      addClipToPlaylist(1778785, "Trudeau takes questions on the campaign trail", "From CTV News Channel: Liberal Leader Justin Trudeau takes questions after making an announcement in Trois-Rivieres, Que. ", thumbnailUrlPlayer, thumbnailUrl);
    }
  </script>
                        
        		<script>
			var adZone = "election2019/home";
			var adSwitch = false;

			if(adSwitch == true){
				var newClip = {
					contentId: 1778785, 
					ad: { adsite: 'ctv.ctvnews', adzone: adZone },
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			} else {
				var newClip = {
					contentId: 1778785, 
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			}
			clipArray.push(newClip);
		</script>
        
        
              
                                  <script type="text/javascript">
        var thumbnailUrlPlayer = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
    var thumbnailUrl = "https://static.ctvnews.ca/bellmedia/common/img/videoPackageThumbBg.jpg";
                    thumbnailUrlPlayer = "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg";
        thumbnailUrl = "https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_150/image.jpg";
        if(isVideoPlayerSupported()){
      addClipToPlaylist(1778730, "Singh takes questions on the campaign trail", "From CTV News Channel: NDP Leader Jagmeet Singh takes questions after making a telecomm announcement in Toronto.", thumbnailUrlPlayer, thumbnailUrl);
    }
  </script>
                        
        		<script>
			var adZone = "election2019/home";
			var adSwitch = false;

			if(adSwitch == true){
				var newClip = {
					contentId: 1778730, 
					ad: { adsite: 'ctv.ctvnews', adzone: adZone },
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			} else {
				var newClip = {
					contentId: 1778730, 
					image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
				};
			}
			clipArray.push(newClip);
		</script>
        
        
        
                              
      
      
                          
    
                  	              <script>
  	var clipArray = [];
  </script>
  
        <script>
   var adSwitch = false;
  	if(adSwitch == false){
	  	var clip = {
	  		contentId: 104070,
	  		ad: {
	  			adsite:"ctv.ctvnews",
	  			adzone:"election2019/home"
	  		},
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
	  	
	  	};
  	} else {
  		var clip = {
	  		contentId: 104070,
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"  	
	  	};
  	}
  	clipArray.push(clip);
  </script>
        <script>
   var adSwitch = false;
  	if(adSwitch == false){
	  	var clip = {
	  		contentId: 1778839,
	  		ad: {
	  			adsite:"ctv.ctvnews",
	  			adzone:"election2019/home"
	  		},
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
	  	
	  	};
  	} else {
  		var clip = {
	  		contentId: 1778839,
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"  	
	  	};
  	}
  	clipArray.push(clip);
  </script>
        <script>
   var adSwitch = false;
  	if(adSwitch == false){
	  	var clip = {
	  		contentId: 1778792,
	  		ad: {
	  			adsite:"ctv.ctvnews",
	  			adzone:"election2019/home"
	  		},
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
	  	
	  	};
  	} else {
  		var clip = {
	  		contentId: 1778792,
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"  	
	  	};
  	}
  	clipArray.push(clip);
  </script>
        <script>
   var adSwitch = false;
  	if(adSwitch == false){
	  	var clip = {
	  		contentId: 1778785,
	  		ad: {
	  			adsite:"ctv.ctvnews",
	  			adzone:"election2019/home"
	  		},
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
	  	
	  	};
  	} else {
  		var clip = {
	  		contentId: 1778785,
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"  	
	  	};
  	}
  	clipArray.push(clip);
  </script>
        <script>
   var adSwitch = false;
  	if(adSwitch == false){
	  	var clip = {
	  		contentId: 1778730,
	  		ad: {
	  			adsite:"ctv.ctvnews",
	  			adzone:"election2019/home"
	  		},
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"
	  	
	  	};
  	} else {
  		var clip = {
	  		contentId: 1778730,
	  		image: "https://www.ctvnews.ca/polopoly_fs/1.4591903.1568388247!/httpImage/image.jpg_gen/derivatives/landscape_620/image.jpg"  	
	  	};
  	}
  	clipArray.push(clip);
  </script>
    
	<script type="text/javascript">
		var genericPlayer;
		requiresDependency('//webapps.9c9media.com/vidi-player/1.7.x/js/player.js', function() {
	      genericPlayer_aritcleVideoContainer = new BMVidiPlayer(
	      { 
	          container: '.'+'aritcleVideoContainer',  
	          config: 'ctvnews/autoplay-off.json'
	      }, clipArray
	      );
	      
	      jQuery(document).trigger('isDone.onGenericPagePlayerSetup', [genericPlayer_aritcleVideoContainer]);
	    });
	</script>

        
            <script type="text/javascript">
  /* ----------------- Event binding ---------------------- */
  // Whenever a video starts, highlight it
	jQuery(document).off('isDone.onGenericPagePlayerSetup').on('isDone.onGenericPagePlayerSetup', function(e, genericPlayer){
		genericPlayer.on('PLAYER_READY', function(){				
					genericPlayer.on('PLAYBACK_STARTED', function(obj){
				    	highlightMobileClip(obj.contentId);
	    			});    				    		
        });
	});
		requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/articlePlayerNavigation.js', function() {
	       requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/slick/slick.min.js', function() {
	               populateElectionPlayerNav();
	           });
	   });
</script>

    
</div>    	        

                                                                  <div class="content-primary electionArticlePrimary" id="responsive_main">
                
	 




  <section class="story project clearfix">

    <div class="container">
      <div class="element article">       
                                
        				          					                          <div class="tools clearfix">
            															<div class="gigya-space">								<span class="shareE"><p>SHARE</p></span>
									      				    <span id="componentGalleryDiv"></span>
    <script type="text/javascript">
              gigya.socialize.showShareBarUI(createShortArticleGigyaParams(gigTitle, gigURL, gigDesc, gigImg, "whenRequired", "https://static.ctvnews.ca", "right"));
          </script>
  								      				    <span id="electionPrint"></span>
    <script type="text/javascript">
    	        gigya.socialize.showShareBarUI(createElectionArticleGigyaParams(gigTitle, gigURL, gigDesc, gigImg, "whenRequired", "https://static.ctvnews.ca", "right"));
          </script>
  								</div>							                        <div class='top-tool gigya-com'>
                            <ul>
                                                                                      </ul>
            </div>
          </div>
            <div class="clearfix">
          <div class="articleBody election-col-11 election-col-s-12 election-col-m-12 election-col-l-10 election-col-xl-11 offset-right-col-l-1 offset-left-col-l-1 offset-left-col-xl-1 offset-left-col-1">
             <p>
	<span class="p_textOutput" id="work_74699">Sights and sounds from the election campaign trail. </span></p>
          </div>
        <div class="image top imgTop-borderless imgMobile election-col-11 election-col-s-12 election-col-m-12 election-col-l-10 election-col-xl-11 offset-right-col-l-1 offset-left-col-l-1 offset-left-col-xl-1 offset-left-col-1">
  <div class="slider-title">RELATED IMAGES</div>
    <div class="blue-box"> </div>
  		<a href="#" class="viewLargerIcon"><span>view larger image</span></a>
        <ul id="articleImage" class="article-image" style="visibility: hidden">
																													                    <li>
                        <div id="mobile1_4591602_864078476_2">
																					                            <a class="galleryitem" href="https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_960/image.jpg" title="Singh takes questions on the campaign trail" alt="" >
								<img title='Singh takes questions on the campaign trail' height='526' alt='Singh takes questions on the campaign trail' width='960' src='https://www.ctvnews.ca/polopoly_fs/1.4591696.1568383362!/httpImage/image.jpg_gen/derivatives/landscape_960/image.jpg' />                            </a>
							                        </div>
                    </li>
							        </ul>

  </div>
  
<script type="text/javascript">
  var mobileArticleImage;
  jQuery(document).ready(function() {
    requiresDependency('https://static.ctvnews.ca/bellmedia/common/js/jquery.bxslider.min.js', function() {
              $('#articleImage').css("visibility", "visible");
    });
    jQuery('a.galleryitem').lightBox();
    jQuery('a.viewLargerIcon').click(function(e){
    	e.preventDefault();
    	jQuery('.activeSlide a').click();
    });
  });

</script>
        <script type="text/javascript">
             var cbAuthor = '';
        </script>
                                      <div class="StoryShareBottom">
  <div class="clearfix"></div>
					<div class="gigya-space">								<span class="shareE"><p>SHARE</p></span>
									      				    <span id="componentElectionDiv"></span>
    <script type="text/javascript">
        gigya.socialize.showShareBarUI(createElctionBottomGigyaParams(gigTitle, gigURL, gigDesc, gigImg, "whenRequired", "https://static.ctvnews.ca", "right"));
    </script>
  								      				    <span id="electionPrintBottom"></span>
    <script type="text/javascript">
    	        gigya.socialize.showShareBarUI(createElectionPrintArticleGigyaParams(gigTitle, gigURL, gigDesc, gigImg, "whenRequired", "https://static.ctvnews.ca", "right"));
          </script>
  								</div>							              
							
							<div class='top-tool gigya-com'>
              <ul> 
                                                                      </ul>
            </div>
						<div class="clearfix"></div>
                        
                                      <div class="form-submit">
                <style type="text/css">
    #lightbox .close {
        max-width:620px;
    }
    
    #lightboxcontent {
        max-width:620px;
    }
    
</style>
        <a href="https://www.ctvnews.ca/report-error-1.1162498?url=https%253A%252F%252Felection.ctvnews.ca%252Fndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602" data-ajax-url="https://www.ctvnews.ca/report-error-1.1162498?ot=AjaxLayout&url=https%253A%252F%252Felection.ctvnews.ca%252Fndp-leader-jagmeet-singh-campaigns-in-toronto-1.4591602" class="lightbox_trigger">Report Error</a>
                </div>
                        <div class="clearfix"></div>
          </div>

                
                        								<div class="currMain">
                



								</div>
                                            



					            

    
  
          										                              



                        					
 
                              
        </div>
      </div>
    </div>
    		      <script type="text/javascript">
       jQuery(function() {
                              jQuery("a.galleryitem").click(function() {
            trackLightbox(false, jQuery(this).attr("title"));
          });
                 });
        
      </script>
			        
        
    						    <script type="text/javascript">
       jQuery(function() {
                                Tracking.setValue(32,"");
                                                     });
        
      </script>
			    
  </section>
  
                  </div><!-- END .content-primary -->
          
    <!-- if(content.righttop || content.boxads) -->
          <div class="content-secondary electionArticleSecondary">
                <div class="sidebar">
                                    



  
  
    

                                    <div class="boxAd ">
							                            <div class="advert">
        
                        
                                                                                              
                	<div id="div-gpt-ad-300_250-4" class="advert-placeholder"></div>
        
<script type="text/javascript">
	if ($(window).width() <= 768 && ("dart" == "boxAd" || "boxAd" == "boxAd") || "dart" == "dart" && $(window).width() <= 768 ) {
	  $( ".articleBody p:eq(1)" ).after($("#div-gpt-ad-300_250-4").closest(".boxAd"));
	}
</script>

  		<script type="text/javascript">
	    if (document.querySelector('.advert') !== null) {
	        googletag.cmd.push(function () {
	            headertag.display("div-gpt-ad-300_250-4");
	        });
	    }
	</script>
          
                    								<p class="ad-below">Advertisement</p>
							            </div>
                
                    </div>
        
    
  
  
  
  
    


  <div class="element list li-divider   ">
              <h3>Federal Election </h3>
                  <ul class="linklist ">
                                                  
    <li class="dc imageLeft">
                                                          
      






  <div style="display: inline-table; " class="element teaser    ">

               	        <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage">
                                      
        <a  href="https://election.ctvnews.ca/trudeau-wouldn-t-close-door-on-intervening-on-bill-21-at-a-later-date-1.4592000"   ><img title='Justin Trudeau ' height='450' alt='Liberal Leader Justin Trudeau makes a policy announcement and holds a media availability at an electric vehicle car dealership during a campaign stop in Trois-Rivieres, Que., on Friday, Sept. 13, 2019. THE CANADIAN PRESS/Sean Kilpatrick' width='800' src='https://www.ctvnews.ca/polopoly_fs/1.4592034.1568391939!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' /></a>

                                            <span class="tag eHub-tag">NEW </span>            </div>
    <div class="bn-headline">
    
              <h2 class="teaserTitle">
                                          
        <a  href="https://election.ctvnews.ca/trudeau-wouldn-t-close-door-on-intervening-on-bill-21-at-a-later-date-1.4592000"   >Trudeau wouldn't close door on intervening on Bill 21 'at a later date'</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                                
    <li class="dc imageLeft">
                                                          
      






  <div style="display: inline-table; " class="element teaser    ">

               	        <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage">
                                      
        <a  href="https://election.ctvnews.ca/scheer-doesn-t-retract-indigenous-hostage-comments-stays-firm-on-position-following-debate-1.4592037"   ><img title='Elizabeth May, Andrew Scheer, and Jagmeet Singh' height='450' alt='Green Party Leader Elizabeth May, left, Conservative Leader Andrew Scheer, centre, and NDP Leader Jagmeet Singh take part during the Maclean&#39;s/Citytv National Leaders Debate in Toronto on Friday, September 13, 2019. THE CANADIAN PRESS/Frank Gunn' width='800' src='https://www.ctvnews.ca/polopoly_fs/1.4592052.1568392409!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' /></a>

                                            <span class="tag eHub-tag">NEW </span>            </div>
    <div class="bn-headline">
    
              <h2 class="teaserTitle">
                                          
        <a  href="https://election.ctvnews.ca/scheer-doesn-t-retract-indigenous-hostage-comments-stays-firm-on-position-following-debate-1.4592037"   >Scheer doesn’t retract Indigenous ‘hostage’ comments, stays firm on position following debate </a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                                
    <li class="dc imageLeft">
                                                          
      






  <div style="display: inline-table; " class="element teaser    ">

               	        <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage">
                                      
        <a  href="https://election.ctvnews.ca/quebec-s-religious-symbols-ban-a-lifeline-for-bloc-stink-bomb-for-liberals-nanos-1.4592032"   ><img title='Quebec religious symbols law' height='348' alt='People attend a demonstration to protest against the Quebec government&#39;s Bill 21 in Montreal, Monday, June 17, 2019. THE CANADIAN PRESS/Graham Hughes' width='620' src='https://www.ctvnews.ca/polopoly_fs/1.4520396.1563914233!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' /></a>

                                            <span class="tag eHub-tag">TREND LINE </span>            </div>
    <div class="bn-headline">
    
              <h2 class="teaserTitle">
                                          
        <a  href="https://election.ctvnews.ca/quebec-s-religious-symbols-ban-a-lifeline-for-bloc-stink-bomb-for-liberals-nanos-1.4592032"   >Quebec's religious symbols ban a 'lifeline' for Bloc, 'stink bomb' for Liberals: Nanos</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                                
    <li class="dc imageLeft">
                                                          
      






  <div style="display: inline-table; " class="element teaser    ">

               	        <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage">
                                      
        <a  href="https://election.ctvnews.ca/jagmeet-singh-promises-ndp-government-would-cap-cellphone-internet-bills-1.4591846"   ><img title='Jagmeet Singh ' height='451' alt='NDP Leader Jagmeet Singh responds to a question during a campaign stop in Toronto, Friday, September 13, 2019. THE CANADIAN PRESS/Adrian Wyld' width='800' src='https://www.ctvnews.ca/polopoly_fs/1.4591901.1568388176!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' /></a>

                                                        </div>
    <div class="bn-headline">
    
              <h2 class="teaserTitle">
                                          
        <a  href="https://election.ctvnews.ca/jagmeet-singh-promises-ndp-government-would-cap-cellphone-internet-bills-1.4591846"   >Jagmeet Singh promises NDP government would cap cellphone, internet bills</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                                
    <li class="dc imageLeft">
                                                          
      






  <div style="display: inline-table; " class="element teaser    ">

               	        <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage">
                                      
        <a  href="https://election.ctvnews.ca/conservatives-promise-to-bring-back-the-public-transit-tax-credit-1.4591756"   ><img title='Conservative Leader Andrew Scheer steps off a publ' height='450' alt='Conservative Leader Andrew Scheer steps off a public transit bus in Mississauga , Ont., Friday, Sept. 13, 2019. THE CANADIAN PRESS/Paul Chiasson' width='800' src='https://www.ctvnews.ca/polopoly_fs/1.4591964.1568390454!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' /></a>

                                                        </div>
    <div class="bn-headline">
    
              <h2 class="teaserTitle">
                                          
        <a  href="https://election.ctvnews.ca/conservatives-promise-to-bring-back-the-public-transit-tax-credit-1.4591756"   >Conservatives promise to bring back the public transit tax credit</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
                                
    <li class="dc imageLeft">
                                                          
      






  <div style="display: inline-table; " class="element teaser    ">

               	        <div class="teaser-image-wrapper teaser-image-top ">
    <div class="teaserImage">
                                      
        <a  href="https://election.ctvnews.ca/trudeau-proposes-to-cut-fees-provide-support-for-smaller-businesses-1.4591714"   ><img title='Liberal Leader Justin Trudeau' height='450' alt='Liberal Leader Justin Trudeau makes a policy announcement and holds a media availability at an electric vehicle car dealership during a campaign stop in Trois-Rivieres, Que., on Friday, Sept. 13, 2019. THE CANADIAN PRESS/Sean Kilpatrick' width='800' src='https://www.ctvnews.ca/polopoly_fs/1.4591938.1568389645!/httpImage/image.jpg_gen/derivatives/landscape_800/image.jpg' /></a>

                                                        </div>
    <div class="bn-headline">
    
              <h2 class="teaserTitle">
                                          
        <a  href="https://election.ctvnews.ca/trudeau-proposes-to-cut-fees-provide-support-for-smaller-businesses-1.4591714"   >Trudeau proposes to cut fees, provide support for smaller businesses</a>

        </h2>
    </div>
    </div>

                  
</div>
                                        </li>
              
            
    </ul>
            <div class="bottom-links">
          </div>
    <div class="clearfix"></div>
</div>

  
                        



                  </div><!-- END .sidebar -->
      </div><!-- END div.content-secondary -->
      </div><!-- END div.content-wrapper -->
</div><!-- END .content -->
<footer class="content-footer election-col-12 election-col-l-12 election-col-m-12 election-col-s-12">
     
      



  
  
        <a href="https://www.bellmedia.ca/sales/political-ads-registry/" class="politicalAdsRegistry">Political Ads Registry</a>
    <p class="terms">Use of this Website assumes acceptance of <a href="https://www.bellmedia.ca/bell-media-website-terms-conditions/" title="Terms &amp; Conditions">Terms &amp; Conditions</a> and <a href="https://support.bell.ca/Billing-and-Accounts/Security_and_privacy/How_does_Bell_respect_my_privacy" title="Privacy Policy">Privacy Policy</a></p>
    <p class="copyright">&#169; 2019<a href="http://www.bellmedia.ca/"><img class="logo" src="https://static.ctvnews.ca/bellmedia/common/img/logos/bell_media_en_white.png" alt="Bell Media" /></a>All rights reserved.</p>

  
          
    <p><a class="back-top hidden" href="#top" title="skip to top of page">Back to top</a></p>

</footer><!-- END #content-footer -->                    
    <script type="text/javascript">
        (function() {
            /** CHARTBEAT CONFIGURATION START **/
            var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});

                        _sf_async_config.sections = 'Federal Election 2019, Federal Election 2019';
            
            _sf_async_config.authors = cbAuthor; // CHANGE THIS TO YOUR AUTHOR NAME(s)
            /** CHARTBEAT CONFIGURATION END **/
            function loadChartbeat() {
            var e = document.createElement('script');
            var n = document.getElementsByTagName('script')[0];
            e.type = 'text/javascript';
            e.async = true;
            e.src = '//static.chartbeat.com/js/chartbeat_video.js';;
            n.parentNode.insertBefore(e, n);
            }
            loadChartbeat();
        })();
    </script>

                      <script type="text/javascript" src="https://tru.am/scripts/custom/ctvnews.js" ></script>
    
        <img src='/logger/p.gif?a=1.4591602&amp;d=/2.628/2.629/2.625/2.985/2.6780' alt='' />    <script type="text/javascript">
    jQuery('body').bind('logger', function(event) {
      if (event.a) {
        if (!event.d) {
          event.d = '/2.628/2.629/2.625/2.985/2.6780';
        }
        jQuery.ajax({url:'/logger/p.gif', data:{a:event.a, d:event.d}});
      }
    });
  </script>
              

          
  <script type="text/javascript"> _AUTO_TRACK = false; </script>
            <script type="text/javascript" src="//beta.ctvnews.ca/content/dam/static-resources/IncludeAdobeAuth3.js"></script>
  <script type="text/javascript" src="https://static.ctvnews.ca/bellmedia/common/js/omnitureTVE.js"></script>
    <script type="text/javascript">
                                
  
   	  	  	         
  setupOmnitureTracking("ctvgmnews",
              "CTV News",
            "News",
            "federal election 2019",
            "story",
            "www",
                              "CTVNews",
                          "false",
            false,
            false,
            "ctvgmnewsglobalsuite");
            
       _satellite.pageBottom();
  
  </script>

         <script type="text/javascript">
      jQuery(document).ready(
      function(){
                                                          trackContent(false, "NDP Leader Jagmeet Singh campaigns in Toronto");
                                    });
      </script>
     </body>
</html>